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What is Excel?
Excel is a spreadsheet program in the Microsoft Office system. You can use Excel to create and
format workbooks (a collection of spreadsheets) in order to analyze data and make more informed
business decisions. Specifically, you can use Excel to track data, build models for analyzing data,
write formulas to perform calculations on that data, pivot the data in numerous ways, and present
data in a variety of professional looking charts.
Common scenarios for using Excel include:











Accounting You can use the powerful calculation features of Excel in many financial accounting
statements—for example, a cash flow statement, income statement, or profit and loss statement.
Budgeting Whether your needs are personal or business related, you can create any type of
budget in Excel—for example, a marketing budget plan, an event budget, or a retirement budget.
Billing and sales Excel is also useful for managing billing and sales data, and you can easily create
the forms that you need—for example, sales invoices, packing slips, or purchase orders.
Reporting You can create various types of reports in Excel that reflect your data analysis or
summarize your data—for example, reports that measure project performance, show variance
between projected and actual results, or reports that you can use to forecast data.
Planning Excel is a great tool for creating professional plans or useful planners—for example, a
weekly class plan, a marketing research plan, a year-end tax plan, or planners that help you
organize weekly meals, parties, or vacations.
Tracking You can use Excel to keep track of data in a time sheet or list—for example, a time sheet
for tracking work, or an inventory list that keeps track of equipment.
Using calendars Because of its grid-like workspace, Excel lends itself well to creating any type of
calendar—for example, an academic calendar to keep track of activities during the school year, or
a fiscal year calendar to track business events and milestones.
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Find and apply a template
Excel 2010 allows you to apply built-in templates, to apply your own custom templates, and to search from a variety of templates on
Office.com. Office.com provides a wide selection of popular Excel templates, including budgets.

To find a template in Excel 2010, do the following:

1. On the File tab, click New.
2. Under Available Templates, do one of the following:
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To reuse a template that you’ve recently used, click Recent Templates, click the template that you
want, and then click Create.
To use your own template that you already have installed, click My Templates, select the template
that you want, and then click OK.
To find a template on Office.com, under Office.com Templates, click a template category, select
the template that you want, and then click Download to download the template from Office.com to
your computer.
NOTE

You can also search for templates on Office.com from within Excel. In the Search Office.com for templates box, type one or more

search terms, and then click the arrow button to search.

For more information about how to find and apply templates, see Create a new workbook.

TOP OF PAGE

Create a new workbook
1. Click the File tab and then click New.
2. Under Available Templates, click Blank Workbook.
3. Click Create.
For more information about how to create a workbook, see Create a new workbook.
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Save a workbook
1. Click the File tab.
2. Click Save As.
3. In the Save As dialog box, in the Save as type list, select Excel Workbook
4. In the File name box, enter a name for your workbook.
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5. Click Save to finish.
TOP OF PAGE

Enter data in a worksheet
1. Click the cell where you want to enter data.
2. Type the data in the cell.
3. Press enter or tab to move to the next cell.
For more information about how to enter data, see Enter data in a worksheet.
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Format numbers
1. Select the cells that you want to format.
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2. On the Home tab, in the Number group, click the Dialog Box Launcher next to Number (or just
press CTRL+1).

3. In the Category list, click the format that you want to use, and then adjust settings, if necessary. For
example, if you’re using the Currency format, you can select a different currency symbol, show more
or fewer decimal places, or change the way negative numbers are displayed.

For more information about how to format numbers and available number formats, see Format numbers in a worksheet or Available number
formats.
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Apply cell borders
1. Select the cell or range of cells that you want to add a border to.
2. On the Home tab, in the Font group, click the arrow next to Borders, and then click the border style
that you want.
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For more information about how to apply formatting to a worksheet, see Format a worksheet.
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Create an Excel table
1. On a worksheet, select the range of cells that you want to include in the table. The cells can be empty
or can contain data.
2. On the Home tab, in the Styles group, click Format as Table, and then click the table style that you
want.

3. If the selected range contains data that you want to display as table headers, select the My table has
headers check box in the Format as Table dialog box.
For more information about how to create a table, see Create an Excel table.
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Apply cell shading
1. Select the cell or range of cells that you want to apply cell shading to.
2. On the Home tab, in the Font group, click the arrow next to Fill Color
Colors or Standard Colors, click the color that you want.
For more information about how to apply formatting to a worksheet, see Format a worksheet.
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Filter your data
1. Select the data that you want to filter.
2. On the Data tab, in the Sort & Filter group, click Filter.
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3. Click the arrow

in the column header to display a list in which you can make filter choices.

4. To select by values, in the list, clear the (Select All) check box. This removes the check marks from all
the check boxes. Then, select only the values you want to see, and click OK to see the results.
For more information about how to filter data, see Filter data by using an AutoFilter.

TOP OF PAGE

Sort your data
To quickly sort your data, do the following:

1. Select a range of data, such as A1:L5 (multiple rows and columns) or C1:C80 (a single column). The
range can include titles that you created to identify columns or rows.
2. Select a single cell in the column on which you want to sort.
3. Click

to perform an ascending sort (A to Z or smallest number to largest).

4. Click

to perform a descending sort (Z to A or largest number to smallest).

To sort by specific criteria, do the following:

1. Select a single cell anywhere in the range that you want to sort.
2. On the Data tab, in the Sort & Filter group, click Sort.
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The Sort dialog box appears.

3. In the Sort by list, select the first column on which you want to sort.
4. In the Sort On list, select either Values, Cell Color, Font Color, or Cell Icon.
5. In the Order list, select the order that you want to apply to the sort operation — alphabetically or
numerically ascending or descending (that is, A to Z or Z to A for text or lower to higher or higher to
lower for numbers).
For more information about how to sort data, see Sort data by using an AutoFilter.
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Create a formula
1. In a cell, type an equal sign (=) to start the formula.
2. Type a combination of numbers and operators; for example, 3+7.
3. Use the mouse to select other cells (inserting an operator between them). For example, select B1 and
then type a plus sign (+), select C1 and type +, and then select D1.
4. Press ENTER when you finish typing to complete the formula.
For more information about how to create a formula, see Create a formula.
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Chart your data
1. Select the data that you want to chart.
2. On the Insert tab, in the Charts group, click the chart type that you want to use, and then click a chart
subtype.
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3. Use the Chart Tools to add chart elements such as titles and data labels, and to change the design,
layout, or format of your chart.

For more information about how to create a chart, see Chart your data.
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Print a worksheet
1. Click the worksheet or select the worksheets that you want to preview.
2. Click File and then click Print.
Keyboard shortcut You can also press CTRL+P.

Note

The preview window will display in black and white, regardless of whether your worksheet(s) includes color, unless you are

configured to print on a color printer.

3. To preview the next and previous pages, at the bottom of the Print Preview window, click Next Page
and Previous Page.
4. To set the printing options, do the following:
 To change the printer, click the drop-down box under Printer, and select the printer that you

want.
 To make page setup changes, including changing page orientation, paper size, and page

margins, select the options that you want under Settings.
 To scale the entire worksheet to fit on a single printed page, under Settings, click the option

that you want in the scale options drop-down box.
5. To print the workbook, do one of the following:



To print a portion of a worksheet, click the worksheet, and then select the range of data that you
want to print.
To print the entire worksheet, click the worksheet to activate it.

6. Click Print.
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For more information about how to print, see Print a worksheet.

TOP OF PAGE

Keyboard shortcuts in Excel 2010
Show All
This article describes what Key Tips are and how you can use them to access the ribbon. It also lists CTRL combination shortcut keys, function
keys, and some other common shortcut keys for Microsoft Excel.

NOTE

If you are using Microsoft Excel Starter 2010, be aware that not all the features listed for Excel are supported in Excel Starter 2010.

In this article





Keyboard access to the ribbon
CTRL combination shortcut keys
Function keys
Other useful shortcut keys

Keyboard access to the ribbon
If you're new to the ribbon, the information in this section can help you understand the ribbon's keyboard shortcut model. The ribbon comes
with new shortcuts, called Key Tips. To make the Key Tips appear, press ALT.

To display a tab on the ribbon, press the key for the tab—for example, press the letter N for the Insert tab or M for the Formulas tab. This
makes all the Key Tip badges for that tab's buttons appear. Then, press the key for the button you want.

Will my old shortcuts still work?
Keyboard shortcuts that begin with CTRL will still work in Excel 2010. For example, CTRL+C still copies to the clipboard, and CTRL+V still
pastes from the clipboard.
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Most of the old ALT+ menu shortcuts still work, too. However, you need to know the full shortcut from memory — there are no screen
reminders of what letters to press. For example, try pressing ALT, and then press one of the old menu keys E (Edit), V (View), I (Insert), and so
on. A box pops up saying you're using an access key from an earlier version of Microsoft Office. If you know the entire key sequence, go
ahead and initiate the command. If you don't know the sequence, press ESC and use Key Tip badges instead.
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CTRL combination shortcut keys
TIP

Download or print a Quick Reference Card: Keyboard Shortcuts - Ctrl keys. (PDF)

KEY

DESCRIPTION

CTRL+PgUp

Switches between worksheet tabs, from left-to-right.

CTRL+PgDn

Switches between worksheet tabs, from right-to-left.

CTRL+SHIFT+(

Unhides any hidden rows within the selection.

CTRL+SHIFT+&

Applies the outline border to the selected cells.

CTRL+SHIFT_

Removes the outline border from the selected cells.

CTRL+SHIFT+~

Applies the General number format.

CTRL+SHIFT+$

Applies the Currency format with two decimal places (negative numbers in
parentheses).

CTRL+SHIFT+%

Applies the Percentage format with no decimal places.

CTRL+SHIFT+^

Applies the Scientific number format with two decimal places.

CTRL+SHIFT+#

Applies the Date format with the day, month, and year.

CTRL+SHIFT+@

Applies the Time format with the hour and minute, and AM or PM.

CTRL+SHIFT+!

Applies the Number format with two decimal places, thousands separator, and
minus sign (-) for negative values.

CTRL+SHIFT+*

Selects the current region around the active cell (the data area enclosed by
blank rows and blank columns).
In a PivotTable, it selects the entire PivotTable report.

CTRL+SHIFT+:

Enters the current time.

CTRL+SHIFT+"

Copies the value from the cell above the active cell into the cell or the Formula
Bar.

CTRL+SHIFT+Plus
(+)

Displays the Insert dialog box to insert blank cells.

CTRL+Minus (-)

Displays the Delete dialog box to delete the selected cells.
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CTRL+;

Enters the current date.

CTRL+`

Alternates between displaying cell values and displaying formulas in the
worksheet.

CTRL+'

Copies a formula from the cell above the active cell into the cell or the Formula
Bar.

CTRL+1

Displays the Format Cells dialog box.

CTRL+2

Applies or removes bold formatting.

CTRL+3

Applies or removes italic formatting.

CTRL+4

Applies or removes underlining.

CTRL+5

Applies or removes strikethrough.

CTRL+6

Alternates between hiding and displaying objects.

CTRL+8

Displays or hides the outline symbols.

CTRL+9

Hides the selected rows.

CTRL+0

Hides the selected columns.

CTRL+A

Selects the entire worksheet.
If the worksheet contains data, CTRL+A selects the current region. Pressing
CTRL+A a second time selects the entire worksheet.
When the insertion point is to the right of a function name in a formula,
displays the Function Arguments dialog box.
CTRL+SHIFT+A inserts the argument names and parentheses when the
insertion point is to the right of a function name in a formula.

CTRL+B

Applies or removes bold formatting.

CTRL+C

Copies the selected cells.

CTRL+D

Uses the Fill Down command to copy the contents and format of the topmost
cell of a selected range into the cells below.

CTRL+F

Displays the Find and Replace dialog box, with the Find tab selected.
SHIFT+F5 also displays this tab, while SHIFT+F4 repeats the last Find action.
CTRL+SHIFT+F opens the Format Cells dialog box with the Font tab selected.

CTRL+G

Displays the Go To dialog box.
F5 also displays this dialog box.

CTRL+H

Displays the Find and Replace dialog box, with the Replace tab selected.

CTRL+I

Applies or removes italic formatting.

CTRL+K

Displays the Insert Hyperlink dialog box for new hyperlinks or the Edit
Hyperlink dialog box for selected existing hyperlinks.

CTRL+L

Displays the Create Table dialog box.
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CTRL+N

Creates a new, blank workbook.

CTRL+O

Displays the Open dialog box to open or find a file.
CTRL+SHIFT+O selects all cells that contain comments.

CTRL+P

Displays the Print tab in Microsoft Office Backstage view.
CTRL+SHIFT+P opens the Format Cells dialog box with the Font tab selected.

CTRL+R

Uses the Fill Right command to copy the contents and format of the leftmost
cell of a selected range into the cells to the right.

CTRL+S

Saves the active file with its current file name, location, and file format.

CTRL+T

Displays the Create Table dialog box.

CTRL+U

Applies or removes underlining.
CTRL+SHIFT+U switches between expanding and collapsing of the formula bar.

CTRL+V

Inserts the contents of the Clipboard at the insertion point and replaces any
selection. Available only after you have cut or copied an object, text, or cell
contents.
CTRL+ALT+V displays the Paste Special dialog box. Available only after you
have cut or copied an object, text, or cell contents on a worksheet or in
another program.

CTRL+W

Closes the selected workbook window.

CTRL+X

Cuts the selected cells.

CTRL+Y

Repeats the last command or action, if possible.

CTRL+Z

Uses the Undo command to reverse the last command or to delete the last
entry that you typed.

TIP

The CTRL cominbations CTRL+E, CTRL+J, CTRL+M, and CTRL+Q are currently unassigned shortcuts.
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Function keys
TIP

Download or print a Quick Reference Card: Keyboard Shortcuts - Function keys. (PDF)

KEY

DESCRIPTION

F1

Displays the Excel Help task pane.
CTRL+F1 displays or hides the ribbon.
ALT+F1 creates an embedded chart of the data in the current range.
ALT+SHIFT+F1 inserts a new worksheet.

F2

Edits the active cell and positions the insertion point at the end of the cell contents. It also
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moves the insertion point into the Formula Bar when editing in a cell is turned off.
SHIFT+F2 adds or edits a cell comment.
CTRL+F2 displays the print preview area on the Print tab in the Backstage view.
F3

Displays the Paste Name dialog box. Available only if there are existing names in the
workbook.
SHIFT+F3 displays the Insert Function dialog box.

F4

Repeats the last command or action, if possible.
When a cell reference or range is selected in a formula, F4 cycles through all the various
combinations of absolute and relative references.
CTRL+F4 closes the selected workbook window.
ALT+F4 closes Excel.

F5

Displays the Go To dialog box.
CTRL+F5 restores the window size of the selected workbook window.

F6

Switches between the worksheet, ribbon, task pane, and Zoom controls. In a worksheet that
has been split (View menu, Manage This Window, Freeze Panes, Split Window command),
F6 includes the split panes when switching between panes and the ribbon area.
SHIFT+F6 switches between the worksheet, Zoom controls, task pane, and ribbon.
CTRL+F6 switches to the next workbook window when more than one workbook window is
open.

F7

Displays the Spelling dialog box to check spelling in the active worksheet or selected range.
CTRL+F7 performs the Move command on the workbook window when it is not maximized.
Use the arrow keys to move the window, and when finished press ENTER, or ESC to cancel.

F8

Turns extend mode on or off. In extend mode, Extended Selection appears in the status line,
and the arrow keys extend the selection.
SHIFT+F8 enables you to add a nonadjacent cell or range to a selection of cells by using the
arrow keys.
CTRL+F8 performs the Size command (on the Control menu for the workbook window) when
a workbook is not maximized.
ALT+F8 displays the Macro dialog box to create, run, edit, or delete a macro.

F9

Calculates all worksheets in all open workbooks.
SHIFT+F9 calculates the active worksheet.
CTRL+ALT+F9 calculates all worksheets in all open workbooks, regardless of whether they
have changed since the last calculation.
CTRL+ALT+SHIFT+F9 rechecks dependent formulas, and then calculates all cells in all open
workbooks, including cells not marked as needing to be calculated.
CTRL+F9 minimizes a workbook window to an icon.

F10

Turns key tips on or off. (Pressing ALT does the same thing.)
SHIFT+F10 displays the shortcut menu for a selected item.
ALT+SHIFT+F10 displays the menu or message for an Error Checking button.
CTRL+F10 maximizes or restores the selected workbook window.

F11

Creates a chart of the data in the current range in a separate Chart sheet.
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SHIFT+F11 inserts a new worksheet.
ALT+F11 opens the Microsoft Visual Basic For Applications Editor, in which you can create a
macro by using Visual Basic for Applications (VBA).
F12

Displays the Save As dialog box.
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Other useful shortcut keys
NOTE

Download or print a Quick Reference Card: Keyboard Shortcuts - Miscellaneous. (PDF)

KEY

DESCRIPTION

ALT

Displays the Key Tips (new shortcuts) on the ribbon.
For example,
ALT, W, P switches the worksheet to Page Layout view.
ALT, W, L switches the worksheet to Normal view.
ALT, W, I switches the worksheet to Page Break Preview view.

ARROW
KEYS

Move one cell up, down, left, or right in a worksheet.
CTRL+ARROW KEY moves to the edge of the current data region in a worksheet.
SHIFT+ARROW KEY extends the selection of cells by one cell.
CTRL+SHIFT+ARROW KEY extends the selection of cells to the last nonblank cell in
the same column or row as the active cell, or if the next cell is blank, extends the
selection to the next nonblank cell.
LEFT ARROW or RIGHT ARROW selects the tab to the left or right when the ribbon is
selected. When a submenu is open or selected, these arrow keys switch between the
main menu and the submenu. When a ribbon tab is selected, these keys navigate the
tab buttons.
DOWN ARROW or UP ARROW selects the next or previous command when a menu or
submenu is open. When a ribbon tab is selected, these keys navigate up or down the
tab group.
In a dialog box, arrow keys move between options in an open drop-down list, or
between options in a group of options.
DOWN ARROW or ALT+DOWN ARROW opens a selected drop-down list.

BACKSPACE

Deletes one character to the left in the Formula Bar.
Also clears the content of the active cell.
In cell editing mode, it deletes the character to the left of the insertion point.

DELETE

Removes the cell contents (data and formulas) from selected cells without affecting
cell formats or comments.
In cell editing mode, it deletes the character to the right of the insertion point.

END

END turns End mode on. In End mode, you can then press an arrow key to move to
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the next nonblank cell in the same column or row as the active cell. If the cells are
blank, pressing END followed by an arrow key moves to the last cell in the row or
column.
END also selects the last command on the menu when a menu or submenu is visible.
CTRL+END moves to the last cell on a worksheet, to the lowest used row of the
rightmost used column. If the cursor is in the formula bar, CTRL+END moves the
cursor to the end of the text.
CTRL+SHIFT+END extends the selection of cells to the last used cell on the worksheet
(lower-right corner). If the cursor is in the formula bar, CTRL+SHIFT+END selects all
text in the formula bar from the cursor position to the end—this does not affect the
height of the formula bar.
ENTER

Completes a cell entry from the cell or the Formula Bar, and selects the cell below (by
default).
In a data form, it moves to the first field in the next record.
Opens a selected menu (press F10 to activate the menu bar) or performs the action
for a selected command.
In a dialog box, it performs the action for the default command button in the dialog
box (the button with the bold outline, often the OK button).
ALT+ENTER starts a new line in the same cell.
CTRL+ENTER fills the selected cell range with the current entry.
SHIFT+ENTER completes a cell entry and selects the cell above.

ESC

Cancels an entry in the cell or Formula Bar.
Closes an open menu or submenu, dialog box, or message window.
It also closes full screen mode when this mode has been applied, and returns to
normal screen mode to display the ribbon and status bar again.

HOME

Moves to the beginning of a row in a worksheet.
Moves to the cell in the upper-left corner of the window when SCROLL LOCK is turned
on.
Selects the first command on the menu when a menu or submenu is visible.
CTRL+HOME moves to the beginning of a worksheet.
CTRL+SHIFT+HOME extends the selection of cells to the beginning of the worksheet.

PAGE
DOWN

Moves one screen down in a worksheet.
ALT+PAGE DOWN moves one screen to the right in a worksheet.
CTRL+PAGE DOWN moves to the next sheet in a workbook.
CTRL+SHIFT+PAGE DOWN selects the current and next sheet in a workbook.

PAGE UP

Moves one screen up in a worksheet.
ALT+PAGE UP moves one screen to the left in a worksheet.
CTRL+PAGE UP moves to the previous sheet in a workbook.
CTRL+SHIFT+PAGE UP selects the current and previous sheet in a workbook.

SPACEBAR

In a dialog box, performs the action for the selected button, or selects or clears a
check box.
CTRL+SPACEBAR selects an entire column in a worksheet.
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SHIFT+SPACEBAR selects an entire row in a worksheet.
CTRL+SHIFT+SPACEBAR selects the entire worksheet.




If the worksheet contains data, CTRL+SHIFT+SPACEBAR selects the current region.
Pressing CTRL+SHIFT+SPACEBAR a second time selects the current region and its
summary rows. Pressing CTRL+SHIFT+SPACEBAR a third time selects the entire worksheet.
When an object is selected, CTRL+SHIFT+SPACEBAR selects all objects on a worksheet.
ALT+SPACEBAR displays the Control menu for the Excel window.

TAB

Moves one cell to the right in a worksheet.
Moves between unlocked cells in a protected worksheet.
Moves to the next option or option group in a dialog box.
SHIFT+TAB moves to the previous cell in a worksheet or the previous option in a
dialog box.
CTRL+TAB switches to the next tab in dialog box.
CTRL+SHIFT+TAB switches to the previous tab in a dialog box.

TOP OF PAGE

See Also:

Customize the ribbon
Use the keyboard to work with Ribbon programs
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Note from your facilitator:
I hope you learned a lot from this course! One of the things I love about Microsoft products is the ease of
access to free training materials. My goal for this workshop is for you to leave here empowered to
educate yourself, at your own pace.
To replay all the training you have received today or to expand your knowledge of this and all the other
Microsoft programs:
When in Excel – click on the help icon in the top right hand side of the program
Type in: “Download Office 2010 Training” in the search bar.
Scroll down to the Excel section or choose any other course you may wish to take. Use a headphones or
speakers, as many of the courses have videos that require you to hear the instructor. Use any of the
computer labs on campus for best results, as our IT staff has outfitted all workstations with the latest 2010
Microsoft Office Suite software. You will note that all earlier versions of excel have downloadable training
as well, (link will be at the bottom of the page).
In addition to that, YouTube is one of my favorite places on the web to go when I want to teach myself
something new. Below are some links that will help you explore further into your Microsoft education
independently. It is best to have a set up with a split screen, use two computers side by side, a tablet and
computer or I have even used my phone to watch the videos while I use my PC to do the work in Excel.
Follow along with the videos in Excel as they teach. Most instructors go slowly enough for you to follow
along. You can always pause the class, which is nice, or rewind if you missed something. Try to watch
the first part of the videos to see the data set they will be using. Create the same set in your worksheet
and it will be easier to follow along.
http://www.youtube.com/watch?v=8L1OVkw2ZQ8&feature=related
For those who get bored with a slow pace, this instructor moves very quickly:
http://www.youtube.com/watch?v=-SnBlC_1tSk&feature=related
This one is a great place to start for chart/graph making:
http://www.youtube.com/watch?v=c70cjQXWkFI
This is the next in the series that will show you how to format your charts:
http://www.youtube.com/watch?v=CGyQmwb3SLk&feature=plcp

Contact me if you have questions or feedback about this workshop at careerservices@heritage.edu
Thank you,
J. Goodrich
Student Affairs Program Assistant
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